
Calculation steps
1) Locate the exercise data in your PC (freely
available from the U.S. Geological Survey:
http://earthexplorer.usgs.gov/).
• C:\....\Data
The data consists of two folders, one for Athens
and one for Budapest.
• C:\....\Data\Athens
• C:\....\Data\Budapest

2) Open the SNAP Toolbox and import the
Landsat 8 data (choose either Athens or Budapest)
(Figure 1).
• File→ Import→ Optical Sensors→

Landsat→ Landsat (Geotiff)

Figure 1



•Select the ….MTL.txt file in the Athens or Budapest folder and click on “Import Product” 
•in the dialog box (Figure 2).

Figure 2



•Now you have imported your data to SNAP toolbox. In the “Product Explorer” window (Figure 3) 
you can see the metadata files and the bands. Familiarize yourself with the toolbox. Double click on any 
band to open the image data. Notice that depending the band, the image changes. 
This is due to the fact that each band refers to a different spectral region.

Figure 3



3) Calculation of Normalized Difference Vegetation Index (NDVI)
The vegetation density can be detected using the reflection values from the red band (Band
4) and the infrared band (Band 5).
Green vegetation reflects more energy in the near- infrared band than in the visible range.
Vegetation absorbs more radiation from the red band for the photosynthesis process. Leaves
reflect less in the near-infrared region when they are stressed, diseased or dead. Features like
clouds, water and snow show better reflection in the visible range then the near-infrared
range, while the difference is almost zero for rock and bare soil. Values close to zero
represent rock and bare soil and negative values represent water, snow and clouds. Taking
ratio or difference of two bands makes the vegetation growth signal differentiated from the
background signal.

𝑵𝑵𝑵𝑵𝑵𝑵𝑵𝑵 =
(𝑵𝑵𝑵𝑵𝑵𝑵 – 𝑵𝑵𝑹𝑹𝑵𝑵)
(𝑵𝑵𝑵𝑵𝑵𝑵 + 𝑵𝑵𝑹𝑹𝑵𝑵)

The SNAP toolbox automatically converts the Digital Numbers (DN) from the raw Landsat 8 
data to the physical measure of Top of Atmosphere (TOA) radiance (Lλ). To calculate NDVI 
we have to convert radiance to reflectance.



Conversion TOA radiance to reflectance for Band 4 (RED) and band 5 (NIR) 
& simple Atmospheric Correction

Calculate the at-surface reflectivity with the following equation:
ρλ=[π·(Lλ - Lp)·d2 / (ESUNλ·cosθs)

where:
ρλ = the surface reflectance, which is “the ratio of reflected versus total power energy” 
Lλ = Spectral radiance 
Lp= the path radiance 
d = Earth-Sun distance in astronomical units (provided with Landsat 8 metadata)
ESUNλ = Mean solar exo-atmospheric irradiances
ESUNλ= π·d2·RADIANCE_MAXIMUM / REFLECTANCE_MAXIMUM
θs = Solar zenith angle in degrees, which is equal to θs = 90° - θe where θe is the Sun elevation 
(provided with Landsat 8 metadata)

The path radiance Lp is the radiance resulted from the interaction of the electromagnetic radiance with
the atmospheric components and it can be calculated with the following equation:

Lp= Lmin – [0.01·ESUNλ·cosθs/(π·d2)]
Where Lmin is the minimum radiance and it can be estimated from the histogram. (Figure 8).



Open the metadata file (e.g. OPEN ATTRIBUTES, MIN – MAX_RADIANCE, MIN-MAX_REFLECTANCE, etc.) 
to find the data you need: d, θe, RADIANCE_MAXIMUM, REFLECTANCE_MAXIMUM (Figure 4). 

Figure 4

Figure 4



•To calculate Lmin open the near_infrared band and select the tab Analysis→Histogram (Figure 5). 

•Click on the refresh button, wait for the histogram to appear and finally zoom in the left-down corner of the
histogram, by pressing left click while drawing a square over the preferred area, in order to estimate 
the value for Lmin (Figure 6). Repeat this step to find the Lmin for the red band.

Figure 5 Figure 6



Athens Budapest

d 1.017

θe 66.755

θs=90-θe 23.245

cosθs 0.9188

RADIANCE_MAX Band 4: 585.192  Band 5: 358.108 Band 4: Band 5:

REFLECTANCE _MAX Band 4: 1.211 Band 5: 1.211 Band 4: Band 5:

ESUNλ Band 4:1570.16 Band 5: 960.86 Band 4: Band 5:

Lmin Band 4: 13.75 Band 5: 4.3 Band 4: Band 5:

Lp Band 4: 9.31 Band 5: 1.583 Band 4: Band 5:

Fill out the table for Budapest



Next we will calculate the reflectance for Band 4 (Name the file refl_red). Select Raster→ Band maths…→ Edit Expression… (Figure 7). 

Be careful to uncheck the Virtual box.

Figure 7



Create the equation refl_red = π·(Lred - Lp)·d2 / (ESUNλ·cosθs) in the Band maths Expression 
Editor (Figure 8).

Figure 8



Repeat the above step (using Bands maths) to calculate the reflectance for band 5 (name it refl_nir ) and then 
calculate NDVI (using Band maths again) (Figure 9).

[ Use the following equations: refl_nir= π·(Lnir - Lp)·d2 / (ESUNλ·cosθs) and 𝑵𝑵𝑵𝑵𝑵𝑵𝑵𝑵 = 𝒓𝒓𝒓𝒓𝒓𝒓𝒓𝒓_𝒏𝒏𝒏𝒏𝒓𝒓− 𝒓𝒓𝒓𝒓𝒓𝒓𝒓𝒓_𝒓𝒓𝒓𝒓𝒓𝒓
𝒓𝒓𝒓𝒓𝒓𝒓𝒓𝒓_𝒏𝒏𝒏𝒏𝒓𝒓+𝒓𝒓𝒓𝒓𝒓𝒓𝒓𝒓_𝒓𝒓𝒓𝒓𝒓𝒓

]

Figure 9



4) Use NDVI to estimate Land Surface Emissivity (LSE)
We will use certain NDVI values (NDVI thresholds method from [2]) to distinguish
between soil pixels (NDVI < NDVIs) and pixels of full vegetation (NDVI > NDVIv).
For those pixels composed of soil and vegetation (mixed pixels, NDVIs ≤ NDVI ≤
NDVIv), the method uses the following simplified equation:

ελ = εvλPV + εsλ(1 − PV ) + Cλ

where εv and εs are, respectively, the soil and vegetation emissivities, PV is the proportion
of vegetation and C is a term which takes into account the cavity effect due to surface
roughness (C = 0 for flat surfaces). Pv can be obtained from NDVI using the following
equation

Pv = [(NDVI – NDVIs) / (NDVIv-NDVIs)] 2

Values of NDVIv = 0.5 and NDVIs = 0.2 will be used in this exercise. In order to obtain
consistent values we set the NDVI value to 0.2 for all pixels with NDVI<0.2 and to 0.5
for all pixels with NDVI>0.5.



LSE will be calculated using the following equations
i. For NDVI≤ 0.2 : LSEs=0.98-0.042·refl_red
ii. For 0.2<NDVI<0.5 : LSEmixed=0.971·(1-Pv)+0.987·Pv

iii. For NDVI≥0.5 : LSEv= 0.99
• Use the Band Maths to create the new NDVI image (you will need a two steps procedure) 
• Create NDVI_2 image by setting the NDVI values to 0.2 for all pixels with NDVI<0.2  (Figure 

10) 
[Select the “Operators” option and select the “if@ then @ else @” option. Use the following 
expression: if NDVI<0.2 then 0.2 else NDVI]

• Create NDVI_3 image from the NDVI_2 image by setting the NDVI value to 0.5 for all pixels 
with NDVI_2 >0.5 

[use the following expression: if NDVI_2>0.5 then 0.5 else NDVI]



Figure 10



•Use the Band Maths to calculate the proportion of vegetation Pv from the NDVI_3 image (Figure 11)
[Remember that Pv = [(NDVI – NDVIs) / (NDVIv-NDVIs)] 2, so use the following expression:
((NDVI_3-0.2)/0.3)* ((NDVI_3-0.2)/0.3) ]

Figure 11



• Use the Band maths to create the Land Surface emissivity (LSE) image from the NDVI_3 image 
(you will need a five steps procedure) (Figure 12)
create LSEs image 
[use the following expression: 0.98-0.042*refl_red ]

create LSEmixed image
[use the following expression: 0.971*(1-Pv)+0.987*Pv ]

create LSE_1 by replacing the values of NDVI_3 <0.201  with the LSEs values (be careful to use     
0.201 instead of 0.2)

[use the following expression: if NDVI_3<0.201 then LSEs else NDVI_3 ]

create LSE_2 by replacing the values of LSE_1=0.5  to 0.99 
[use the following expression: if LSE_1==0.5 then 0.99 else LSE_1 ]

create LSE by replacing the values of LSE_2<0.5 to LSEmixed
[use the following expression: if LSE_2<0.5 then LSEmixed else LSE_2 ]



Figure 12



Land surface temperature (LST) calculation
The Single Channel algorithm developed by Jiménez-Muñoz et al. [3] retrieves land 
surface temperature (LST) using the following general equation:

LST= γ·[1/LSE·(ψ1·Lsen + ψ2) + ψ3] + δ
where LSE is the surface emissivity, and γ (gamma) and δ (delta) are two parameters 
given by 

γ ≈ 𝑻𝑻𝒔𝒔𝒓𝒓𝒏𝒏
𝟐𝟐

𝒃𝒃𝜸𝜸𝑳𝑳𝝀𝝀
δ ≈ 𝑻𝑻𝒔𝒔𝒓𝒓𝒏𝒏 −

𝑻𝑻𝒔𝒔𝒓𝒓𝒏𝒏𝟐𝟐

𝒃𝒃𝜸𝜸

where Tsen is the at-sensor brightness temperature of the thermal band, bγ = c2/λ 
(bγ=1324 for band 10); and ψ1, ψ2, and ψ3 are the so-called atmospheric functions, 
given by

ψ1=
𝟏𝟏
𝝉𝝉

ψ2=−𝑳𝑳𝒓𝒓 −
𝑳𝑳𝒖𝒖
𝝉𝝉

ψ3=𝑳𝑳𝒓𝒓
where τ is the atmospheric transmission, , Lu is the upwelling or atmospheric path
radiance, Ld is the downwelling or sky radiance. These parameters can be estimated
using the Atmospheric Correction Parameter Calculator which can be found in:
http://atmcorr.gsfc.nasa.gov/.



Using the calculator the following results for Athens and Budapest are obtained for the dates of
our data:
Athens
Date (yyyy-mm-dd):   2017-06-28
Input Lat/Long:   37.980/ 23.730 
GMT Time:  9:04
L8 TIRS Band 10 Spectral Response Curve
Mid-latitude summer standard atmosphere 
Band average atmospheric transmission:    0.74
Effective bandpass upwelling radiance:    2.19 W/m^2/sr/μm
Effective bandpass downwelling radiance:  3.57 W/m^2/sr/μm

Budapest

Date (yyyy-mm-dd): 2017-05-30
Input Lat/Long: 47.480/19.030
GMT Time: 9:32
L8 TIRS Band 10 Spectral Response Curve
Mid-latitude summer standard atmosphere
Band average atmospheric transmission: 0.73
Effective bandpass upwelling radiance: 2.08 W/m^2/sr/μm
Effective bandpass downwelling radiance: 3.40 W/m^2/sr/μm



Athens Budapest

τ 0.74 0.73

Lu 2.19 2.08

Ld 3.57 3.40

Ψ1 1.3513 1.3698

Ψ2 -6.53 -6.25

Ψ3 3.57 3.4

The table below provides the ψ1, ψ2 and ψ3 values (use them in your 
calculations)



Conversion to At-Satellite Brightness Temperature
TIRS band data can be converted from spectral radiance to 
brightness temperature using the thermal constants 
provided in the metadata file and the following equation:

𝑇𝑇
𝑠𝑠𝑠𝑠𝑠𝑠= 𝑘𝑘2

ln(𝑘𝑘1𝐿𝐿𝜆𝜆
+1)

where:
Tsen = At-satellite brightness temperature (K)
Lλ = TOA spectral radiance (Watts/( m2 * srad * μm))
K1 = Band-specific thermal conversion constant from 
the metadata (K1_CONSTANT_BAND_x, where x is the 
thermal band number)
K2 = Band-specific thermal conversion constant from 
the metadata (K2_CONSTANT_BAND_x, where x is the 
thermal band number)
• Use the Create Band from Math Expressions to 

calculate LST (you will need a four step procedure)
• Create the brightness temperature (name it Tsen ) for 

band 10 (TIRS_1)
[Use the expression: 
1321.0789/(log((774.8853/’thermal_infrared_(tirs)_1’)+
1)). Find the log in the “Functions”] (Figure 13). Figure 13



Create γ (name it gamma). ( Remember that γ ≈ 𝑻𝑻𝒔𝒔𝒓𝒓𝒏𝒏
𝟐𝟐

𝒃𝒃𝜸𝜸
)    

[use the following expression: (Tsen*Tsen)/(1324*’thermal_infrared_(tirs)_1’)] 

Create δ (name it delta). ( Remember that δ ≈ 𝑻𝑻𝒔𝒔𝒓𝒓𝒏𝒏 −
𝑻𝑻𝒔𝒔𝒓𝒓𝒏𝒏𝟐𝟐

𝒃𝒃𝜸𝜸
)

[ use the following expression: Tsen-((Tsen*Tsen)/1324) ]
Create the land surface temperature image (name it LST). (Remember that LST=  γ·[1/LSE·(ψ1·Lsen + ψ2) + ψ3] + δ)
[use the following expression:  gamma*((1/LSE)*(1.3513*’thermal_infrared_(tirs)_1’-6.53)+3.57)+delta ]

Figure 13 (again)



Finally use the colour manipulation tool to colour your LST image (Figure 
14). You can zoom in your area of interest (Athens or Budapest) (Figure 15).

Figure 14



Figure 14



A. Monitoring the urban heat island of Athens and 
Budapest with the use of Sentinel 3 data

In this exercise we will use the SLSTR Level-2 LST product which provides land surface parameters
generated on the wide 1 km measurement grid.

It contains measurement files with Land Surface Temperature (LST) values with associated
parameters (LST parameters are computed and provided for each pixel included in the 1 km
measurement grid.

It also contains data of Normalized Difference Vegetation Index (NDVI), GlobCover surface
classification code (noted biome), fractional vegetation cover and total column water vapour.



1) Open the SNAP Toolbox and import the Sentinel 3 data
• Select File→ Import→ Optical sensors→ Sentinel-3→ Sentinel-3 (Figure 16)

Figure 16



Select the first file in the Sentinel 3 folder of Athens (Figure 17), open the
xfdumanifest.xml file that is inside it and click on “Import Product” in the dialog box
(Figure 18). This image was acquired on 12 July 2017 at 08:42 UTC as it can be
extracted from the filename “S3A_SL_2_LST__20170712T084222…” so it is suitable
for the monitoring of the daytime urban heat island.

Figure 17 Figure 18



Now you have imported the Sentinel 3 data to SNAP toolbox. In the “Product Explorer” window you
can see the metadata files and the bands. Double click on the LST band to open the image data. In the
“Pixel info” window you can see that the LST is given in Kelvin (Figure 19). Notice the wide spatial
coverage of the Sentinel 3 data compared to the Landsat 8 data.

Figure 19



Next we will reproject the Sentinel 3 data to the coordinates reference system of Landsat 8 (EPSG:32634)
• Select Raster→ Geometric Operations→ Reprojection (Figure 20).

Figure 20



• In the Reprojection window select the Reprojection parameters tab and select the “Predefined
CRS” option (Figure 21). “Select” the EPSG:32634 by typing the number 32634 in the Filter section.
In the I/O Parameters tab select a folder to save the reprojected data.

Figure 21



Your reprojected data will appear in the “Product Explorer” window. Open the LST band of
the new image [indexed as (2)] and zoom in the wider Athens area.
Right-click in the image and select “Spatial Subset from View…” (Figure 22).

Figure 22



• In the “Specify Product Subset” window select the “Band Subset” tab and select only the LST,
NDVI, biome and fraction bands (Figure 23). Press “OK” and then “NO” in the message that pops
up about the flags.

Figure 23



Choose the newly estimated image (named as subset) and use the colour manipulation tool to colour
your subset image (Figure 24).

Figure 24



4) In order to monitor the nighttime urban heat island we should repeat the same steps for the nighttime
image.
To save computational time we have already processed the nighttime image. You can open it by selecting
File→ Open Product and opening the file “subset_Athens_night.dim” that you will find in the Athens→
Sentinel 3 folder of your data (Figure 25).

Figure 25



5) Colour your nighttime image and compare the LST distribution of the daytime and nighttime data.
In addition you can find a subset daytime image of the LST of Budapest in the Budapest→ Sentinel 3
folder (Unfortunately no nighttime cloud free image of Budapest was available during the
development of this tutorial).

References
[1]Jimenez-Munoz, J.C.; Sobrino, J.A.; Skokovic, D.; Mattar, C.; Cristobal, J., "Land Surface
Temperature Retrieval Methods From Landsat-8 Thermal Infrared Sensor Data," in Geoscience and
Remote Sensing Letters, IEEE , vol.11, no.10, pp.1840-1843, Oct. 2014.doi:
10.1109/LGRS.2014.2312032
[2]Sobrino, J.A.; Jimenez-Muoz, J.C.; Soria, G.; Romaguera, M.; Guanter, L.; Moreno, J.; Plaza, A.;
Martinez, P., "Land Surface Emissivity Retrieval From Different VNIR and TIR Sensors," in
Geoscience and Remote Sensing, IEEE Transactions on , vol.46, no.2, pp.316-327, Feb. 2008 doi:
10.1109/TGRS.2007.904834
[3]J. C. Jiménez-Muñoz, J. Cristóbal, J. A. Sobrino, G. Sòria, M. Ninyerola, and X. Pons, “Revision
of the single-channel algorithm for land surface temperature retrieval from Landsat thermal-infrared
data,” IEEE Trans. Geosci. Remote Sens., vol. 47, no. 1, pp. 339–349, Jan. 2009.




	Slide Number 1
	Slide Number 2
	Slide Number 3
	Slide Number 4
	Slide Number 5
	Slide Number 6
	Slide Number 7
	Slide Number 8
	Slide Number 9
	Slide Number 10
	Slide Number 11
	Slide Number 12
	Slide Number 13
	Slide Number 14
	Slide Number 15
	Slide Number 16
	Slide Number 17
	Slide Number 18
	Slide Number 19
	Slide Number 20
	Slide Number 21
	Slide Number 22
	Slide Number 23
	Slide Number 24
	Slide Number 25
	Slide Number 26
	Slide Number 27
	Slide Number 28
	Slide Number 29
	Slide Number 30
	Slide Number 31
	Slide Number 32
	Slide Number 33
	Slide Number 34
	Slide Number 35
	Slide Number 36

